The first OS X Application Bundle !

Everything related to the code /
Tout ce qui touche au code
Post Reply
milipili
Posts: 545
Joined: Thu Nov 02, 2006 8:52 am
Location: Paris (France)
Contact:

The first OS X Application Bundle !

Post by milipili » Sun Sep 28, 2008 4:49 pm

The first fully working OS X application Bundle is ready !
It still needs various improvements but it works (MacIntel only - PPC
on request)

You just need to put .ccx and .hpi files from the original CDRom into
"~/Library/Application Support/ta3d" and that's all :)

http://ta3d-download.shikami.org/binaries/darwin/intel/
Damien Gerard
Ta3d & Yuni Developer

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Post by Balthazar » Sun Sep 28, 2008 5:07 pm

Cool! Is there anyone who can test it?

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Post by zuzuf » Sun Sep 28, 2008 8:28 pm

Woow !! Does that mean TA3D supports more platforms than Spring now ?
=>;-D Penguin Powered

milipili
Posts: 545
Joined: Thu Nov 02, 2006 8:52 am
Location: Paris (France)
Contact:

Post by milipili » Sun Sep 28, 2008 9:16 pm

It seems so :)

I think a little howto in the wiki would be appropriate (with screenshots). And perhaps a post in some Mac forum ? (the only needs is to copy files to make it work on OS X, like other OS X apps)
Damien Gerard
Ta3d & Yuni Developer

milipili
Posts: 545
Joined: Thu Nov 02, 2006 8:52 am
Location: Paris (France)
Contact:

Post by milipili » Sun Sep 28, 2008 9:26 pm

Hum may be after some tickets (related to OS X) are closed :D
Damien Gerard
Ta3d & Yuni Developer

khamual
Posts: 3
Joined: Sat Jan 03, 2009 8:35 am

Resources Error

Post by khamual » Sat Jan 03, 2009 8:47 am

I've loaded btdata.ccx, btmaps.cxx, ccdata.cxx, ccmaps.cxx, totala2.hpi and totala4.hpi from the CDs into my ~/Library/Application Support/ta3d folder (and I've also tried with them in the ~/Library/Application Support/ta3d/resources folder), but when I start the application a window pops up saying:

ta3d
RESOURCES ERROR

If I start the program from the command line, I get the following (and the error window too):

iMac:~ user$ /Applications/ta3d.app/Contents/MacOS/ta3d
[Sat Jan 3 00:28:22 2009] [infos] *** Welcome to TA3D ***
[Sat Jan 3 00:28:22 2009] [infos] Version: 0.5-WIP (r1320)
[Sat Jan 3 00:28:22 2009] [infos] [paths] Started from: `/Applications/ta3d.app/Contents/MacOS`
[Sat Jan 3 00:28:22 2009] [infos] [paths] Preferences: `/Users/user/Library/Preferences/ta3d/`
[Sat Jan 3 00:28:22 2009] [infos] [paths] Cache: `/Users/user/Library/Caches/ta3d/`
[Sat Jan 3 00:28:22 2009] [infos] [paths] Savegames: `/Users/user/Library/Application Support/ta3d/savegames/`
[Sat Jan 3 00:28:22 2009] [infos] [paths] Screenshots: `/Users/user/Downloads/`
[Sat Jan 3 00:28:22 2009] [infos] [paths] Logs: `/Users/user/Library/Logs/ta3d/`
[Sat Jan 3 00:28:22 2009] [infos] Opened the log file: `/Users/user/Library/Logs/ta3d/ta3d.log
[Sat Jan 3 00:28:22 2009] [infos] [resources] Added `/Applications/ta3d.app/Contents/MacOS/../Resources/`
[Sat Jan 3 00:28:22 2009] [infos] [resources] Added `/Users/user/Library/Application Support/ta3d/`
[Sat Jan 3 00:28:22 2009] [infos] [resources] Added `/Applications/ta3d.app/Contents/MacOS`
[Sat Jan 3 00:28:22 2009] [infos] [system] Vendor: i486 Itanium (cpuid, x87 FPU)
[Sat Jan 3 00:28:22 2009] [infos] [system] MacOSX (10.5)
[Sat Jan 3 00:28:22 2009] [infos] [system] Desktop: 1440x900 (32bits)
[Sat Jan 3 00:28:22 2009] [infos] [system] Allegro version: 4.2.2 (2007)
[Sat Jan 3 00:28:22 2009] [infos] [system] AllegroGL version: 0.4.3
[Sat Jan 3 00:28:22 2009] [error] [tdf] Unable to open `/Users/user/Library/Preferences/ta3d/ta3d.cfg`
[Sat Jan 3 00:28:22 2009] [error] [settings] Impossible to load the settings from `/Users/user/Library/Preferences/ta3d/ta3d.cfg`
[Sat Jan 3 00:28:22 2009] [warns] [i18n] Impossible to load translations from `gamedata\translate.tdf` (file not found)
[Sat Jan 3 00:28:22 2009] [warns] [i18n] Impossible to load translations from `ta3d.res` (file not found)
[Sat Jan 3 00:28:22 2009] [error] RESOURCES ERROR
RESOURCES ERROR[Sat Jan 3 00:29:39 2009] [infos] Aborting now. Releasing all resources...
[Sat Jan 3 00:29:39 2009] [debug] [i18n] Release.
[Sat Jan 3 00:29:39 2009] [infos] Exit.

I've also tried using the --install option, but it throws up the same error.

Any thoughts?

milipili
Posts: 545
Joined: Thu Nov 02, 2006 8:52 am
Location: Paris (France)
Contact:

Post by milipili » Sat Jan 03, 2009 12:07 pm

Yes I saw this recently. I am trying to find out the real problem.
Damien Gerard
Ta3d & Yuni Developer

milipili
Posts: 545
Joined: Thu Nov 02, 2006 8:52 am
Location: Paris (France)
Contact:

Post by milipili » Sat Jan 03, 2009 1:53 pm

The problem has been fix in the r1366. If you can use the svn please try it, otherwise I will make you a new bundle
Damien Gerard
Ta3d & Yuni Developer

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Post by zuzuf » Sat Jan 03, 2009 3:50 pm

beware that trunk contains work in progress code, it may be broken whereas the branch/ta3d_0_5 folder contains bug fixes for the 0.5 branch (but with the WIP flag set), currently this branch contains several bug fixes that don't break anything.
=>;-D Penguin Powered

khamual
Posts: 3
Joined: Sat Jan 03, 2009 8:35 am

New Bundle

Post by khamual » Sat Jan 03, 2009 6:13 pm

Damien,

If you wouldn't mind making a new bundle, I'd appreciate it greatly.

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Post by zuzuf » Sat Jan 03, 2009 7:07 pm

Also if you have time, we need a MacOS X download page to go with the Linux and windows ones :wink:
=>;-D Penguin Powered

milipili
Posts: 545
Joined: Thu Nov 02, 2006 8:52 am
Location: Paris (France)
Contact:

Post by milipili » Sat Jan 03, 2009 7:15 pm

Damien Gerard
Ta3d & Yuni Developer

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Post by zuzuf » Sat Jan 03, 2009 11:52 pm

I've added a link to it in the website menu :)
=>;-D Penguin Powered

khamual
Posts: 3
Joined: Sat Jan 03, 2009 8:35 am

New Bundle

Post by khamual » Sun Jan 04, 2009 2:38 am

The new bundle works great. Thanks very much.

neuralshock
Posts: 28
Joined: Sun Apr 05, 2009 3:31 pm

Post by neuralshock » Sat Apr 11, 2009 3:27 pm

Is it possible to get some build instructions for 0.5.x or 0.6.x?

Cheers

Post Reply

Who is online

Users browsing this forum: No registered users and 15 guests