Issues with CMake, 2.6.4 recommended

Everything related to the code /
Tout ce qui touche au code
Post Reply
milipili
Posts: 545
Joined: Thu Nov 02, 2006 8:52 am
Location: Paris (France)
Contact:

Issues with CMake, 2.6.4 recommended

Post by milipili » Wed Aug 05, 2009 9:01 pm

There are a lot of issues with CMake 2.6.2 (the current version on Ubuntu for example), mainly fixed in 2.6.3, but I would recommend the 2.6.4.
Nothing really important but if you encounter any issue or strange behavior with CMake, please consider upgrading.
Damien Gerard
Ta3d & Yuni Developer

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Re: Issues with CMake, 2.6.4 recommended

Post by zuzuf » Wed Aug 05, 2009 10:02 pm

what kind of issue do you have with 2.6.2 ? I am running Kubuntu Jaunty with cmake 2.6.2, I didn't see any problem ...
=>;-D Penguin Powered

milipili
Posts: 545
Joined: Thu Nov 02, 2006 8:52 am
Location: Paris (France)
Contact:

Re: Issues with CMake, 2.6.4 recommended

Post by milipili » Wed Aug 05, 2009 11:17 pm

From what I encoutered and tested myself:
We had some problem with the testsuite in libyuni for example (parsing issue). `make test` only works with cmake >=2.6.3.
At work, a colleague had a problem with FindGettext.
A lot of issues on OS X with static libraries and bundle creation (an issue remains with source_group however, when used with XCode)
The `properties` are really buggy with 2.6.2.

I think there were updates about FindQT{4} but I don't know exactly what.
Damien Gerard
Ta3d & Yuni Developer

Post Reply

Who is online

Users browsing this forum: No registered users and 10 guests