UTF8 Issue

Everything related to the code /
Tout ce qui touche au code
Post Reply
milipili
Posts: 545
Joined: Thu Nov 02, 2006 8:52 am
Location: Paris (France)
Contact:

UTF8 Issue

Post by milipili » Mon Jul 13, 2009 6:42 pm

I've got this on OS X :
http://ftn.shikami.org/ta3d/utf8.jpg

There is obviously a bug with the utf8 charset. As I am not able to have a working Windows or Linux, could someone tell me if there is the same issue on other platforms ?
Thanks
Damien Gerard
Ta3d & Yuni Developer

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Re: UTF8 Issue

Post by Balthazar » Mon Jul 13, 2009 7:21 pm

Works fine for me. WinXP.

milipili
Posts: 545
Joined: Thu Nov 02, 2006 8:52 am
Location: Paris (France)
Contact:

Re: UTF8 Issue

Post by milipili » Mon Jul 13, 2009 7:54 pm

snif :'(
Damien Gerard
Ta3d & Yuni Developer

xpoy
Posts: 669
Joined: Mon Sep 22, 2008 3:55 am

Re: UTF8 Issue

Post by xpoy » Tue Jul 14, 2009 8:05 am

also worked, win XP :P
Maybe due to font.

milipili
Posts: 545
Joined: Thu Nov 02, 2006 8:52 am
Location: Paris (France)
Contact:

Re: UTF8 Issue

Post by milipili » Tue Jul 14, 2009 8:51 am

The font is the same as far I know. I would suspect bad calls to FTGL instead. But I really don't like to debug such things :(
Damien Gerard
Ta3d & Yuni Developer

xpoy
Posts: 669
Joined: Mon Sep 22, 2008 3:55 am

Re: UTF8 Issue

Post by xpoy » Tue Jul 14, 2009 2:42 pm

remeber already fix a analogous bug in win32
Maybe need make a new MAC pack?

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Re: UTF8 Issue

Post by zuzuf » Sat Jul 25, 2009 6:00 pm

what encoding is used in your languages/*.po files ? That kind of text corruption usually happen when a UTF8 text is processed as an ASCII text which could happen during a conversion process like ASCII(UTF8 processed as ASCII) -> UTF8

Maybe there is something wrong with subversion there (I think it can convert text files to local encoding in some cases which is not good here since we always expect UTF8).
=>;-D Penguin Powered

milipili
Posts: 545
Joined: Thu Nov 02, 2006 8:52 am
Location: Paris (France)
Contact:

Re: UTF8 Issue

Post by milipili » Sat Jul 25, 2009 6:11 pm

No problem with svn neither editor. My vim propertly display japanese.po. Perhaps the loding indeed. Or a bad use of FTGL on OS X
Damien Gerard
Ta3d & Yuni Developer

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Re: UTF8 Issue

Post by zuzuf » Sat Jul 25, 2009 6:17 pm

I think only the last version of FTGL supports UTF8, previous versions support Unicode only through wchar :(
=>;-D Penguin Powered

milipili
Posts: 545
Joined: Thu Nov 02, 2006 8:52 am
Location: Paris (France)
Contact:

Re: UTF8 Issue

Post by milipili » Sat Jul 25, 2009 6:46 pm

Aaaaah that's why :p
Damien Gerard
Ta3d & Yuni Developer

Post Reply

Who is online

Users browsing this forum: No registered users and 10 guests